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Preface

This document describes how to install the IAR Embedded Workbench (EW)
IDE and the corresponding Puya IAR pack. Then, it starts from scratch
to create a new project to output “Hello World” using the serial port,
and to port and debug from the existing Microcontroller Development
Kit (MDK) Version 5 — Keil project. Finally, we will add the functions
that may be used in the process of using IAR.
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Installation of IAR EW for Arm 9.20.2 User Manual

1 Installation of IAR EW for Arm 9.20.2

1.1 Software acquisition, download

Table 1.1 - 1 Software Download Links

Software Description Download Links
https:.//www.iar.com/products/architectures/arm/iar-
IAR IAR EW for Arm 9.20.2
embedded-workbench-for-arm/
Tool & Software - Puya Semiconductor/Download -
IAR Pack Puya.lAR.DFP.VO1

Code Cloud - Open Source China (gitee.com)

1.2 1AR Software Installation
Once the IAR installation package has been downloaded, click on the installer.

Figure 1.2-1 Installation procedure

4

EWARM-9202-4
3979%.exe

The installation screen in Figure 1.2-2 below will pop up, click the "Next" button to continue the
installation.

Figure 1.2-2 Welcome screen

Welcome to the Install5hield Wizard for l1AR
Embedded Workbench For Arm

The InztallShield “Wizard will ingtall |1AR Embedded
Warkbench for Arm on your computer. To continue, click,
Mext,

< Back Mt Cancel
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You need to check the agree agreement before proceeding to the next step of installation.

Figure 1.2-3 Software License Agreement

Licensze Agreement
Fleaze read the following license agreement carefully. < >

SOFTWARE LICENSE
AGREEMENT

April 2021

Concerningthe Products: Embedded Trust , |1AR Embedded Workbench™ | IAR
Yisual State”,

0 | accept the terms of the license agreement Print

()| do not accept the terms of the licenze agreement

< Back Mext » Cancel

Select the appropriate USB driver to install as required.

Figure 1.2-4 USB driver installation

I1AR Embedded Workbench for Arm 9.20.2 b
USB Dnver installation
Select the USE drivers toingtall for your debug probes _\?

Select the USE drivers you want ta inztall an your system

- TIFTDI Description

- TIICDI Crrivvers for USE copy
=8 Debug probe drivers [interactive installers) pratection dongles
- B FEMicio
= . REE
- TIFET
- MU-LINE,

~ Diangle driverz

7. BB GB of zpace required oh the F drive
933.15 GBE of gpace available on the F drive

< Back Cancel
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Create a folder in the start menu and click "Next" to proceed to the next step of the installation.

Figure 1.2-5 Selecting the program folder
IAR Embedded Workbench for Arm 9.20.2 *

Select Program Folder

Please zelect a pragram folder. <
prog ~

Setup will add program iconz o the Program Folder listed belov. v'ou may bppe a new folder
hame, of zelect ane fram the Existing Folders list. Click Mest o continue,

Program Folder:

|45 EW far Arm 9.20.2

Exizting Folders:

Accezsibility

Accezsones

Administrative Tools
FileZilla FTP Client

Fowrnail

M aintenance

Micrasaft Office 2016 T B
Microsaft Office T B

< Back Cancel

The installer is ready to install the program, click "Next" to proceed to the next step of the installation.

Figure 1.2-6 Ready for installation
IAR Embedded Workbench for Arm 9.20.2 o4

Heady to Install the Program <
The wizard iz ready o begin installation.
it N4

Click Inztall to begin the installation.

IF pou want ko review or change any of your installation settings, click Back. Chck Cancel to exit
the wizard.

< Back [rztall Cancel
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Wait for the installer to install.

Figure 1.2-7 Installation in progress

Setup Status

IAR. Embedded Workbench for Arm is configuring your new software installation.

Installing

Fil... \armiconfig\debugger \MXPYMCIME 7L _M4,svd

Cancel

Installation completed

Figure 1.2-8 Installation completed
IAR Embedded Workbench for Arm 9.20.2

Inztall5hield Wizard Complete

The InstallShield Wizard haz successfully installed 14F
Embedded “Warkbench far Arm. Chck Finish to exit the wizard.

Wiew the release notes

< Back Cancel
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After the installation is complete, the USB driver will be installed, a new window will pop up, click the
"Install" button
Perform the installation.
_ - Figure 1.2-9 USB driver installation -
’ Windows E2mH % |

{REEEX MNREDE?

EF: AR Systems
Z#E: Signum Systems Corp

@ L5 EEF=E "Signum Systems Corp” BIERIEA) =20

o

U RV RIS a2 aEFwE. =

1.3 IAR Pack Installation

Extract the IAR Pack zip file.

Unzip the following files, and copy the "config" folder as shown in Figure below to the arm folder
in the IAR installation directory. For example: C:\Program Files\IAR Systems\Embedded
Workbench 9.0\arm.

Puya Semiconductor 7 /pPuya
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Replace the "config" folder in the red box in Figure below.
Figure 1.3-1 IAR Pack installation path
- a X
e
BE ,
4 EEGE ES:] N
o BRiEAsE
meE » bin ZDZZEEJ:E‘S 33 =
‘Tﬁ ’ 2022/6/16
TR *
=B8R *
Downloads | drivers
- TR (D) xampl
ERER ;’:
b ER plug
@ OneDri RTOS
= e tutorials 2022/6/16 15:29
[= 2=t
13498 E=
Select "Replace files in target".
Figure 1.3-2 Replace or skip file options
wy STt

— *
1IF#E# 61 -MEEM. Puya AR.DFPVOT 33 arm
BirEE 49 MEEEF

v EIRERPISER)

P BHIE(S)
B iERREE L)

ERE

ill}

=
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2 Software Use

2.1  New project

Open the TAR EW for Arm software and click on the menu bar “Project” —> “Create New

Project”.

Figure 2.1-1 New construction

Workspace

& 1AR Embedded Workbench IDE

File Edit View | Project | Tools Window Help

‘Do Ea

[@ | Add Files...
Ce | Add Group...

[41| import File List...

Files

O Coenenme

Add Project Connection...
Edit Configurations...

# | Remove

£* | Options... Alt+F7
Version Control System b

0 | Make F7
B  compile Ctrl=F7
@ | Rebuild Al

& | Clean

& | Batch build... F8

Clean Browse Information

In the new window, select "Empty project” (if you select C/C++, it will have main.c in the new

project) and click "OK".

Semiconductor 23

Figure 2.1-2 New project option

Create Mew Project

Toaol chair: | Arrm

v|

Project templates:

-E1 Externally built executable
i % Emply CMSISPack project

Description:

Creates an empty project.

| o

Cancel
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Next, the Save window pops up and select the appropriate path to save.

Figure 2.1-3 Save to

@ Save As

4 > HEE > ZF s Pro <)

E=Eh HETEE

~

E=4 BWEE ESic) Fh

 BEAE
W =m

¥ T
T
= BR

| EWARM

ESEREHIE.

., Puya
| EEEm
| e

@ OneDrive

o g

v

1L Pro RS

Pro|

STHE(N):

FFEE(T): | Project Files (“.ewp)

~ BEnER

[[(Eme || =

Then click "File"->"Save Workspace" to save the workspace.

Figure 2.1-4 Save workspace

& AR Embedded Workbench IDE - Arm 9.20.2

E’ E Edit View Project Simulator Tools Window Help
T NewFile

Tj Mew Workspace

!
Ctrl+N

-l < Q>

5  OpenFile...
E Open Workspace...

Ctri=2

B_-] Open Header/5ource File
& Close
) sovewokspace |

Ctri+5hift+H

Ctrl+F4

a Close Workspace

ﬁ Save
ﬁ Save As..

A save Al

Ctrl=5

% Page Setup...

B | Print...

Recent Files

Ctri+P

-

e + B

After saving in the workspace, there will be a file with the project name .eww in the project folder,

which can be clicked directly to open the EWARM project.

Figure 2.1-5 Project Icon

Pro.eww

After the above steps are completed, there will be a project file in the software, right-click on the
project file and select "Add" to add the file. (Add File for adding files, Add Group for creating

Puya Semiconductor
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folders)

Figure 2.1-6 Adding a group

© Pro - 1AR Embedded Warkbench IDE - Arm 9.20.2

File Edit Wiew Project Simulator Tools Window Help

Debug

Files o

[ |Pro - Debug ——
Options..

Make
Compile
Rebuild All
Clean

C-STAT Static Analysis b

Stop Build

Remave

Add Files...
Add Group...

Rename...
Version Contral System H

Open Containing Folder...
File Properties...

Set as Active

Click Add Group and enter the name of the folder in the new pop-up window to create the folder
in the following figure. The Output folder does not need to be created, it will be generated

automatically when compiling.

Figure 2.1-7 Enter group name
Add Group - Pro

Group hame:

[Cirive |

s

Cancel

Figure 2.1-8 Directory structure
Workspace * 0 X

| [ebug w

Files o
= @ Pro - Debug * v
— & Doc
-£1 B Drivers

— mBsP

B CMSIS
£1 B Example

B EYARR

B User
B Output

Click the menu bar File->New File, right-click the title of the new file, name it main.c and save it .

Figure 2.1-9 Create a new file and save it

Puya Semiconductor

Semiconductor 23
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&G >8e=< G D

Untitled1 x

Save Untitled1

Close

Close All But This

Close All to the Right
Open Containing Folder...
File Properties...

After the save is complete, right-click the User folder, Add->Add "main.c" to add the file you just
saved, if you already have main.c you can click Add->Add Files to add it directly.

Figure 2.1-10 Adding "main.c"

i— B Drivers
L& & Example
F— B EvWARM
I_E-‘ B
Lg Options...
Make
Compile
Rebuild All
Clean

C-STAT Static Analysis

Stop Build

Add Add Files...

R Add "main.c”
emove

Rename... Add Group...

Version Contral System

Open Containing Folder...
File Properties...

Set as Active

When you create a new project, you need the corresponding files, which should be copied to the
project folder.

Semiconductor 23

B main.c
D Pro.dep
[ Pro.ewd

D Pro.ewp
D Pro.ewt

py32flxch
py32f030x8.h

T startup_py32f030x8.s
[ system_py32f0oc.c
system_py32flhoch

usart.h

2022/6/29 14:34
2022/6/29 14:01

2022/6/29 1

2022/6/29 14:33
2022/6/24 18:15
2022/2/9 14:41

2022/2/9 14:50
2022/2/9 14:48
2022/6/29 14:19
2022/6/29 11:27

C Source

DEP =CiF

EWD X{g

EWP Iz{f

EWT Z2f4

AR IDE Worksp...
C/C++ Header
C/C++ Header
Assembler Source
C Source

C/C++ Header

C Source

C/C++ Header

Puya Semiconductor

1KB
5 KB
108 KB
74 KB
208 KB
1KB
7 KB
366 KB
11 KB
KB
KB
KB
KB

Fu | LN

w
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The "starup_py32f030x8.s" file should be added to the Example->EWARM folder (Note: the
startup file of EWARM is different from that of MDK, which is explained in the next section of the
porting project), and the "syste py32f0xx.c" file should be added to Drivers->CMSIS folder, and
the file structure is built as below.

Figure 2.1-12 File structure

Waorkspace * O X

[ebug w

Files i+
E @ Pro - Debug v
— mDoc
&1 W Drivers
— EBsP
Lg Ecmsis
systern_py32ilxcc
= M Example
21 i EwWARM
| L— B startup_py32030x8.s
Lo @ User
main.c
usart.c
B Output

Right-click the project and select "Options" to set it.
Figure 2.1-13 Project Settings

#include
Files fd #include
EL IPro - De| : lude
— Options...
— i Doc dels
= H Drivars el
|— & asF | main(
L s v Compile b 1
5 Rebuild All =
2 & Examp Clean intf(
|21 o B
| L Rast  C-STAT Static Analysis » [-EIT
Lasuse . R
m Stop Build IFY
u Add > lile
W Output
Remaove SET_B
Helay
Rename...
SET_B
Version Control System > Helay
Open Containing Folder...
File Properties... dels
Set as Active v

You can select the corresponding device by selecting "General Options->Target->Device" in the
settings. If there is no Puya option in the list, please refer to the previous article on the Pack
installation process to install or reinstall.

Figure 2.1-14 Selecting a device

Optians for node “Pro” AnalogDevices

>
ARM >
Asell >
Broadcom >
[Genersioptens ] o N
Runtine Checking Epson >
¢ 4 bemncfanisusation Library Options 1 Library ¢ EtaCompute >
" b b ¢ arada >
Output Converter EL EHE Faraday
Custom Buid . Fujitsu >
Processor variant
Buld Actions . )
Lirker Cortex-M0+
Debugger Octere GigaDevice >
Simuator HDSC ’
oL @ Device Puya PY32F003x8
Hilscher >
csis Dap
GDB Server OcCMsIs-Pack  None Holtek >
et HSXP-HK >
Tuikf}Trace
>
T stelaris Execution mode Infineon
Nudink e 5
FEma Linear >
ST
Third-Party Driver Maxim >
TsP-FET Mediatek >
s Micrachip >
Micranas >
Microsemi >
Milandr >
MindMotion >
MitsubishiElectric >
Netsilicon >
0 e NordicSemi >
Nuvoton >
NXP >

< I Puya ’ I PY32F0 > PY32FO03 > |
PVIDFOI0c > Puya PY32F030x3

Puya PY32F030x4

pl

>
Redpine > Puya PY32F030x6
Renesas > Puya PY32F030x7
Samsung y Puya PY32F030x8

T

In the setting "C/C++ CompiIer>Preprocessor->Addifiorial include directories:(one per line)", you

Puya Semiconductor 13/pPuya
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can add the include path. "$TOOLKIT_DIR$\CMSIS\Core\include" is the core include in the
installation directory.

~ Figure 2.1-15 Adding an include path

Categony: Factory Settings

General Options [ Multiile Compilation

Static Analysis Discard Unused Publics
Runtime Checking

C/C ++ Compiler Language 1 Language 2 Code Optimizations Output
Assembler
Qutput Converter
Custom Build
Build Actions [ignore standard include directorie:
Linker
Debugger Additional include directories: (one per line)
Simulator $TOOLKIT_DIR$\CMSIS\Core\Include

CADL

CMSIS DAP
GDE Server
Iget
JHink/I-Trace
TI Stellaris
Nu-Link

PE micro
ST-LINK
Third-Party Driver Defined symbols: (one per line)

TLMSPFET PY32F030x8 [JPrepracessor output to file
TLXDS

List Preprocessor  Diagnostics  Encodings  Extra Options

Preserve comments

Generate #line directives

| ak. Cancel |

In "C/C++ Comp'iIer>Preprocessor->Defined symbols:(one per line)" settihg, you can add
definitions.

Figure 2.1-16 Adding Definitions

Categon: Factory Settings
General Options [ Multi-file Compilation
Static Analysis Dizcard Unused Publics
Runtime Checking
Language 1 Language 2 Code Optimizations Qutput
Assembler List Preprocessor Diagnostics Encodings  Extra Options
Qutput Converter
Custom Build
Build Actions [Jignere standard include directorie:
Linker - . . . .
Debugger Additional include directories: (one per line)
Simulator $TOOLKIT DIRS\CMSIS\Core\Include
CADI
CMSIS DAP
GDB Server
Liet
J-Link/1-Trace
T Stelaris Preinclude
Nu-Link
PE micro
ST-LIMNK
Third-Party Driver Defined symbols: (one per ling)
TIMSPFET PY32F020x8 [ 1 Preprocessor output to file
TIXDS
Preserve comments
Generate #line directives

0K Cancel

Puya Semiconductor 14 /Puya
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After setting all the files, paths and definitions you can compile, click the button in the red box to
compile. The message window indicates Done. 0 error(s), 0 warning(s)

Figure 2.1-17 Compilation

@ Fro - 1AR Embedded Workbench IDE - Arm 9.20.2 - o b
P et vew fross CHSSDP Took Winsow e
DAES e XB0DC JeG S esg /-_Hmzo-,i=
Workipace * 8 X mainc x e -
Db v fur
|
o SETEITT I | il
#0Doc woid delay(uintd2_t nline)
W Drivers
& BsP int nain(void)
| Lodcmss .
| L@ B system_pyi2iicc TSR na U
|-e1 S Exampls printf ("hello world!\r\n")
i W:m;in_nﬂmml“ SET_BIT(ROC->10PENR,  RCC_TOFENR_GPIOARN) - //izR T0A# S84
o User W EPATL DTSR
= B maine _FEG (GPI0A->NODER. GPIO_MODER_WODEIL_L. GPIO_NODER_NODE11_0)
| L@Busetc
L@ Output -
SRR, GPIO_BSRR_BS11)://PA1l @il & F
L
SET_BIT (GPIOA->BSKR. 0_BSER_ERI1) : //PALI B E#F
delay (0xFFFFF) i
wvoid delay(uint32_t nTime)
Ly while (nline—)

5 z s
e =
Messages File Line

Reading project nodes.
mtine
Dion. 0 emorfs). 0 waming(s)
Ready Emors O Wamings 0 Ln 33, Coi | hinese Simplitied (G £B BF 5 e
Next, download the program to the MCU for testing, connect the PY32F030xx8 to the PY-LINK

via SWD, connect the PA9 pin to the RX pin of the UART, and connect the PY-LINK emulator to
the PC. In "Debugger>Setup->Driver", select "CMSIS DAP" and check "Run to main" on the right

side of the project. ".

Figure 2.1-18 Debugger device selection

Options for node *Pro”

Categony:

General Options
Static Analysis
Runtime Checking
CfC++ Compiler
Assembler
Qutput Converter
Custom Build
Build Actions
Linker
Simulator
CADL
CMSIS DAP
DB Server
Iget
I-ink/1-Trace
T1 Stellaris
Nu-Link
PE micro
ST-LINK
Third-Party Driver
TIMsSPFET
TIXDS

Factory Settings |

Setup  Download Images Multicore Extra Options Plugins

Driver

[F1Run to

main

CMSIS DAP

[Use macro file(s)

Device description file
[ override default

$TOOLKIT_DIR$\CONFIG\debugger\Puya\PY32F003x8.ddf

Semiconductor 23
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When using PY-Link connection, you need to set "CMSIS DAP -> Interface -> Interface" to TMHz
in the settings to download, otherwise an error window may pop up.

Figure 2.1-19 Interface frequency selection

Options for node "Pro”

Category:

General Options
Static Analysis
Runtime Checking
CfC++ Compiler
Assembler
Output Converter
Custom Build
Build Actions
Linker
Debugger
Simulator
CADI

Probe config
® Auta
O From file

(O Explicit

Setup Interface  Breakpoints

Probe configuration file

Override default

Select

Factory Settings

GDB Server

et ITAG
Idink/3-Trace
TI Stellaris
Nu-Link

PE mico
STLINK 0
Third-Party Driver
TIMSP-FET
TIXDS

Interface Explicit probe configuration
Multi-target debug system
SWD -

Target with multiple CPUs

Interface

1MHz

Cancel

Figure 2.1-20 Error pop-up window

Execution failure in flash loader,

oK

After setting, click "Project->Download-> Download active application" to download. (If you use
this function often, please refer to section 2.3.3 and place this function in the toolbar.)

..Figure 2.1-21 Download program

w [Project | CMSIS-DAP Tools Window Help
2 | o addFiles.
s Add Group...
=1 [41| import File List...

< Q> KrEC

Add Project Connection... " pv3zilxzx.h”

Edit Configurations. [ asazt. b
Remore by (uint32_t nTime}
rs
P |1 Create New Project.. (void)
ASIE 8 add Existing Project... nit ()
sys
wple| #  options... Alt=F7 ["hello world!\rin®)
WAR |
o T , | (RCC=» TOPERR, RCC_IOPENR_GPIDAE!
o A1 il Ty S
i @ Make F7 |REG (GPIOA->NODER, GPIO_NODER_NOI
usal B Compile anF7 |y
i @ Rebuild Al
IT(GPI04->EBSRR, GPIO_BSRR_BSL1)
2 Clean (OxFFFFF) 1./ 80
& | Batch build.. P8 JIT(GPI0A->BSER, GPIO_ESRR_BEL1)
(DxFFFEF) /3
Clean Browse Information
C-STAT Static Analysis » .
fay (uint32_t nTime)
Stop Build CrlsBreak fpive entine—)
© Download and Debug Ctr+D

Debug without Downlaading

) | Attach to Running Target

Make & Restart Debugger ctrl+R
Restart Debugger Ctri+Shift=R
Download » Download active application
Download file...
SFR Setup ownload fle
Erase memory
& | CMSIS-Pack Manager
Open Device Desaiption File »

Save List of Registers...

After successful download, open the serial‘ port tool on your computer. Since the routine specifies
the checksum method, baud rate and other information in the file, you need to select the same

Puya Semiconductor 16 /Puya
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options as the file in the tool.
Figure 2.1-22 Serial Receive Options

COMe : USE—SERETAL v
i E
it |1 v
Mgl s ~

Firka i Even v
BORE @ xifB0
Press the Reset button of the development board, the serial tool displays the following figure.

Figure 2.1-23 Serial port output
hello world!
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2.2  Transplantation project

This section briefly describes porting a project from MDK, most of the operations are the same
as the new project in the previous section, you need to add files to the project, but the way to
write the startup file is different, especially the way to write interrupts, which should be modified

when porting.

Flie Eot View Projet CMSISOAP Took Window Hew

DWW & A0 DC 1 LQ 0 S

v 3 X | sorp pyszmns x
[ <
Files °

© ®Project - Debug

ol

Warkspace

SE
£0712_3_TagHandler
& EXT12_3_IRQHendler

PUBNEAK EXT18_15_IAQHsndler
SECTION _text:CoE
ExT1s_15_TRgrandler
B EXTI4_15_TRgHan

21 i ivers

1515,

32F020_HAL Diver

L wUser

Da1_channel2_3 TRgrandler
® DAl Channelz 3 TRgrandler

EAK ADC_COPP_TAQHaNd]er

A0C_CoNp_TRGHand ler
B ADC_CONP_IRQHandLer

PUBNEAK TIHM1_CC_TRQHandler
SECTION . text:CODE:REORDER:NOROOT (1)
TI_cc_Tagandler
B TIML_CC_TRQHandler

PUBNEAK TIM3_IRQHendler

TINS_IRQanéler
& TIM_lagandler

PUBNEAK LPTIFI_TRGHand]

s
PTI T
®

TN TROMAA e

=

Debug log

Figure 2.2-1 Comparison of startup files

CTION . text : CODE:REQRDER - HORDOT (1) ~

$RECRDER:NOROOT (1)

SECTION . text:COOE :REGRDER-NORODT (1)

SECTION .text:CODE:REORDER:NOROOT(1)

SECTION . text: CODE:REORDER:NOROOT (1)
et CODF 1REORDER :OROTT (1)

PUBNEAK TIM14_TRQHsndler
SECTION . text:CODE:REORDER: WOR0OT (1)

VAL Firmware Y0010
@| @

| © 88 e ] cormeons @ K] &
Project 8

R0

Window Helo

1 scetine 15 GRO_ PN

vae a-le

4 Project P10 Toggle
£ GP0_Toge Debug
5@ Commen
2) startup_py320030005
) system py32foen.c
5 23 Applcation

) py32f0x_hal_corter.c

@ ovss

« <
~ 8 X Deroed @ [ [RE \ Text Editor {_Configuration wasrd /.

Log
Wad Jun 29. 202210 16.03 AR E:

Bt Output

[REAK)

(WERK)

(WEK)

wec Jun 83603 File notfounc C

bench C.dly

Wac Jun 29. 202216 1603 Loading e CMSIS-DAR divvar

In the project settings "C/C++ Compiler>Preprocessor->Additional include directorieg:(one

32 ProbeScipt

per

line)" you can add include paths, such as: "$PROJ_DIRS\... \Drivers\CMSIS\Include".

Figure 2.2-2 Adding an include path

. Options for node "Project”

Categany:

General Options
Static Analysis
Runtime Checking
Assembler
Qutput Converter
Custom Build
Build Actions
Linker
Debugger
Simulator
CADL
CMSIS DAP
GDB Server
Iget
Jdink{I-Trace
TI Stellaris
Mu-Link.
PE micra
STLINK
Third-Party Driver
TI MSPFET
TIXDS
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Factory Settings
[ Multi-file Compilation

Discard Urused Publics

Language 1 Code

List

Language 2 Optimizations Output

Preprocessor Extra Options

Diagnostics  Encodings

[ignore standard include directories

Additional include directories: (one per ling)

$PROJ_DIRS\.\.\Drivers\PY32F0oc HAL Driver\Inc
$PROJ_DIR$Y,\.\Drivers\CMSI5\Device\PY32FDod Include
$PROJ_DIRS\.\..\Drivers\CMSIS\Include]
$PROJ_DIRS\.\,\Drivers\BSP\PY32F030xx_Start Kit
$PROJ_DIR$\.\Inc

Preinclude

Defined symbals: (one per line)

PY32F030x8
USE_HAL_DRIVER

[JPreprocessor output to file
Preserve comments

Generate #line directives

Cancel
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After successful compilation, you can enter debugging mode and click the button in the red box
in the figure to debug.
Figure 2.2-3 Debug button

BAE L /UUH.EE:E:

The interface during debugging is shown below. The buttons in the red box can end the
simulation, and the buttons in the blue box can control the steps of the simulation (Single Step,
Full Speed, Reset, etc.).

Figure 2.2-4 Debugging procedure

© Project - 1AR Embedded Warkbench IDE - Arm 9.20.2 - o x
File Edit View Project Debug Disassembly CMSIS-DAP Tools Window Help
NDOER@ = XK DC -\Q,s-5<v>uu|.-E©En1r---1. em o i ]
Workspace ~ B X Disassembly vax
Debug v| Gow: | zone: | Memary v
Files o Disassembly A
B ® Project - Debug v 0x800° 0218 OxelD0'edlc  DC32 SHER2
27DataTabled_5
M Drivers 0x800' Oalc: 0xe000'=400  DC32 022000 =400
e mesp ?7DataTabled_8
| ) py3210300¢_Start_Kitc 0x800' 0220 Dze000'e014  DC32 SYST_RVR
— Ecmsis ?7DataTables_9
Pv32F030_HAL_Driver 0x800'0a24: Dze000'e018  DC32 0me000" 5018
) py32fxc_hal.c ?7DataTabled_10
[ py321ibox_hal_canex.c 0x800'0228: 0xeD00'=010  DC32 0xe000° 010
[ py32f0oe_hal_gpio.c __asabi_idiv0
[ py32tibo_hal_ree.c 0x800' 0a2c: 0x4770 BX IR
xample B FVD_IRGHandler
|8 i EwaRM 0x800' 0a2e: Dxe?fe B.N 02800 0222
| D) startup_py32i030.s int main(void) .
i User -
main.c X -
i
7 USER CODE BEGIN Feader #/ Py
o

# §ile  femplates/Src/main. c
# Sauthor MU Application leam
# §hrief Main program body

#
/# USER CODE BiD Header #/
/* Includes
#include “main.h”
/#® Private includes

/% Private typedef

/# Private define

/% Private macro

/# Private variables
Project < > v

Debug Log vax

Log -~
Thu Jur 30, 2022 09:32:25: Download cormpleted

Thu Jun 30, 2022 09:32:25: LowlevelReset(software, delay 200)

Thu Jun 30, 2022 09:32:25: Targetreset

Thu Jun 30, 2022 09:32:25: INFO: Configuring trace using "MTB' setting

Thu Jun 30, 2022 09:32:25: INFO: ON-Chip (ETBAMTE) race made is not suppored by this processar - frace is disabled

Build  Debug Log

Ready Errors 0, Warnings 0 Ln 16, Col 81 Chinese Simplified (GB2312) <5 EIF M5 2=
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2.3 Common Functions

2.3.1 Compiler Optimization

The project settings "C/C++ Compiler>Optimizations->Level" allows you to adjust the
optimization level of the compiler.

Figure 2.3.1-1 Compiler Optimization

| Options for node “Pro’

Category

Factory Settings
General Options

Static Analysis
Runtime Checking
List

Assembler

[ Mulifile Compilation
Discard Unused Publics

Preprocessor  Diagnostics

Code

Encodings  Extra Options

oot Comverter Language 1 Language 2 Optimizations
Custom Buid
Build Actions
Linker
Debugger
Simulator
CADI

CMSIS DAP
GDB Server
et
JHink/)-Trace
T stelaris
MuLink

PE micro

Output
Level

O None
®ow

O Medium
O High

Enable

Balanced

Ng size constraint:

STAINK
Third-Party Driver
TIMSP-FET
TIXDS

For details, please refer to the instructions in the IAR online help, which can be found in
the menu bar "Help->Content", by following the path shown below.

Cancel

Figure 2.3.1-2 Online help file

[ Help for IAR Embedded Workbench for Arm 9.10.

9 B o+ = o 5

BE =R L mE =R I
BRO 3N RS )

IAR Systems

[5] 1AR online help
= ([ IDE Project Management and Building
= @ The development environment
= @ Project management
= @ Building projects
= @ Editing
= @ Product files
= @ Menu reference
= @ General options Lewel Erstiedtardoreasans
= () Compiler optians e .

: Optimizations

Optimizations

The Optimizations options determine the type and level of optimization for the generation of abject code.

re——

= () Description of compiler options edm
[2] Multi-file Compilation
[?] Language 1
[7] Language 2
[7] Code
[7] Optimizations
[2] Cutput
[ List
[7] Preprocessor
[?] Diagnostics
[2] Encedings
[7] Extra Options
[2] Edit Include Directories dialoc

Level »
Selects the optimization level:
None
Mo optimization; provides best debug support

= @ Assembler aptions

= @ Output converter options

= @ Custom build options

= @ Build actions options

= @ Linker options

@ @ Library builder options

5 @ Glossary

= @ Debugging using C-SPY

< >

Low
The lowest level of optimization
Medium
The medium level of optimization
High, Balanced
The highest level of optimization, balancing between speed and size.
High, Size
The highest level of optimization, favors size.

Hiah. Speed

2.3.2 Generate hex file

In the project settings "Output Converter> Output”, you can check "Generate additional
output", and in the following "Output format" select "Intel Extended hex" to generate a

".hex" file at compile time, the generated file is located in The generated file is located
under "\Debug\Exe" path in the project folder.

Semiconductor 23
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2.3.3

~ Figure 2.3.2-1 Generate hex file options

' Options for node "Pro”

Categorny:

General Options

Static Analysis

Runtime Checking
C/C++ Compiler
Assembler

Output Converter

Custom Build
Build Actions
Linker
Debuager
Simulator
CADI
CMSIS DAP
GOB Server
I4et
J-ink{1-Trace
TI Stellaris
Nu-Link
PE micro
STLINK
Third-Party Driver
TI MSP-FET
TIXDS

Customize Toolbar

Output

Factary Settings

Generate additional output

Output format:

Intel Extended hex

o

Raw binary
Simple-code

Maotorala 5-records

Texas Instruments TI-TXT

Carcel

Click the small triangle on the rightmost side of the toolbar, as shown in the figure, and
click "Add or Remove Button -> Customize" in order to pop up the customization window,
as shown in the figure below.

Semiconductor 23

Figure 2.3.3-33 Customizing the toolbar

. 0

> I

T

Arnak Bz

Main 2
ChSIS-Pack 4

Customize...
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Figure 2.3.3-34 Customization window

®wE  Em 1B

ZE1(G): =5 (D):
O ) NewFie A
Efﬁt ™ New Workspace
View . .
Project [ Open File...
CMSIS-DAP ] Open Workspace...
Toals [%] Open Header/Source File
Window &) Close
g&egﬁi B Save Workspace
FrEsss @ Save Workspace As..
& Close Workspace
E ?ave _ 9
15ER:

S|
Find the icon you need to use, and drag it into the toolbar by holding down the mouse to
fix the icon to the toolbar, as shown in the figure.

Figure 2.3.3- Dragging the desired icon
P AN R@ =0 - WU

E x|
LEES ER @ TBEE
#=E(0):
Match All Brackets (grow) ~
" Match All Brackets (shrink]
WView 5
Project @ Toggle All Folds
CMSIS-DAP *= Auto Indent
Tools
Window
Help i
e oggle breakpoin
Faas Enable/Disable Breakpoint
o Next Error/Tag
O Previous Error/Tag "
152ER: Uncomment a block of text
i
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3 Version History

Version Date Description

V1.0 2024-06-12 | Initial version

PUY)

Puya Semiconductor Co., Ltd.

IMPORTANT NOTICE

Puya Semiconductor reserves the right to make changes without further notice to any
products or specifications herein. Puya Semiconductor does not assume any
responsibility for use of any of its products for any particular purpose, nor does Puya
Semiconductor assume any liability arising out of the application or use of any of its
products or circuits. Puya Semiconductor does not convey any license under its patent
rights or other rights nor the rights of Puya Semiconductor does not convey any license
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